Question Adresses MAC sur les cartes mères à double carte réseau


Voici un problème étrange.

Nous avons un certain nombre de périphériques avec des cartes mères à double carte réseau. Certains sont des cartes réseau Realtek, qui sont nulles. Certains sont des Intel e1000, ce qui n'est pas le cas.

Je viens de remarquer sur 2 machines, l’une est une carte réseau Intel, l’autre est une Realtek, que lorsque Je mets l'adresse MAC d'une machine dans le dhcpd.conf fichier sur notre serveur DHCP pour le faire démarrer par PXE dans un environnement de reconstruction, au début tout va bien.

Le serveur obtient une allocation DHCP et PXE démarre dans l'environnement de préconfiguration Ubuntu.

Sur une ou deux machines, cela va aussi loin que la configuration du réseau DHCP d'Ubuntu et ça échoue. Si je tire un shell busybox (sur tty2 sur la machine d’installation), et lancez ip link, Je peux voir que le drapeau UP est placé sur le autre NIC.

Voici quelques trucs.

  host xeon16-ghz240-gb48-node1 {
        hardware ethernet BC:AE:C5:07:1F:18;
        filename "pxelinux.0";
        next-server 192.168.123.80;
  }

C'est ce qui est dedans dhcpd.conf

Voici à quoi ressemble le lien ip sur la machine perverse. ip link output

Une seule carte réseau est réellement connectée (délibérément).

Comme vous pouvez le constater, la carte réseau figurant dans la configuration de dhcpd n’est pas marquée comme UP et le lien qui s’ajoute à UP ne correspond pas à celui de DHCP.

Jusqu'à présent, j'ai vu cela sur deux marques de configuration à double carte réseau.

Est-ce que quelqu'un sait 1) ce qui le cause, et b) Que pouvons-nous faire à ce sujet?


9
2018-01-27 15:50


origine


1. Ordre différent d’initialisation des périphériques PCI. Le BIOS utilise donc le MAC ": 18" et le système d'exploitation utilise d'abord le "" 19 "MAC. 2. Aucune idée =] - Chris S
J'ajouterai ceci sous forme de commentaire plutôt que de réponse car il est assez faible, mais je peux dire que quelqu'un avant moi a trouvé exactement le même problème et l'a résolu en ajoutant MAC et MAC + 1 au dhcpd.conffichier lors de la configuration d’un Kickstart. - Kyle Smith
A quoi ressemble le preseed? Plus précisément, est netcfg/choose_interface ensemble? - Shane Madden♦
./master/master_preseed.cfg:d-i netcfg/choose_interface select auto - Tom O'Connor
@ KyleSmith Ouais .. C'est un peu stochastique cependant. - Tom O'Connor


Réponses:


Il y a toujours plus d'une façon de faire quoi que ce soit :)

Solution 1

Les cartes mères avec un de chaque?

Liste noire quel que soit le module (ethtool -i eth0) supporte la carte Realtek.

Ubuntu les soutiens  module_name.blacklist=yes de la mettre au liste noire au démarrage et vous devriez pouvoir modifier les options de modprobe dans l’environnement de préconfiguration afin qu’il ne soit pas vérifié ultérieurement.


Solution 2

Permettez-moi de reformuler le problème:

Nous avons des cartes mères avec deux cartes réseau et nous voulons qu'elles fonctionnent de manière cohérente, quelle que soit l'interface connectée. Nous ne pouvons pas toujours déterminer quelle interface (du point de vue du système d'exploitation) sera connectée.

Mettre en place le collage! Utilisez une configuration active-passive (mode=active-backup miimon=100) avec les deux interfaces comme esclaves. De cette façon, cela fonctionnera toujours, quelle que soit l'interface connectée.


Solution 3

Les cartes mères sont-elles suffisamment cohérentes pour que les cartes réseau apparaissent toujours sur le même ID PCI? Utilisez les règles udev pour toujours attribuer la carte à une adresse PCI particulière à eth0 et la carte de l’autre adresse à eth1.

Notez que vous pouvez avoir deux règles udev différentes qui affectent un périphérique à eth0. Cela vous permet de gérer les cas Realtek et e1000 en même temps.


8
2018-01-28 16:15



Ils sont tous les deux Realtek tristement .. Je vais avoir quelques e1000 pour les remplacer, alors ils vont probablement les tuer dans le bios. - Tom O'Connor
Ooohhhh, incompris. Je pensais que vous aviez des cartes mères avec 1 x e1000 et 1 x Realtek. - MikeyB
Bonnes réponses .. Je ne suis pas tout à fait sûr de ce qui est pris en charge car ce problème a tendance à se présenter entre le chargeur PXE et le serveur DHCP de l’installateur Debian. Personnellement, je pense que la meilleure option sera de désactiver tout sauf un bon Intel NIC - Tom O'Connor
Nous avons fini par configurer la liaison et résoudre le problème en mettant les deux adresses dans DHCP. - Tom O'Connor


Vous pouvez essayer d'ajouter PXELINUX IPAPPEND 2 option dans votre fichier pxelinux.cfg pour indiquer aux scripts d’initialisation d’utiliser l’interface qui a effectué l’amorçage PXE:

/var/lib/tftpboot/pxelinux.cfg/default

LABEL linux
   KERNEL /ubuntu/casper/vmlinuz 
   APPEND initrd=/ubuntu/casper/initrd.gz root=/dev/nfs boot=casper netboot=nfs nfsroot=192.168.1.1:/var/lib/tftpboot/ubuntu --
   IPAPPEND 2

voir: http://www.syslinux.org/wiki/index.php/SYSLINUX#IPAPPEND_flag_val_.5BPXELINUX_only.5D


5
2018-06-20 19:36