Question Comment installer la bibliothèque GD en php?


quand j'ai essayé d'utiliser la fonction imagefromjpeg () en PHP, il a renvoyé une erreur. Alors, j'ai essayé d'installer la bibliothèque GD en utilisant la commande suivante:

sudo apt-get install php5-gd

Mais j'ai l'erreur suivante.

 php5-gd : Depends: php5-common (= 5.5.9+dfsg-1ubuntu4) but 5.5.10+dfsg-1+deb.sury.org~saucy+1 is to be installed
E: Unable to correct problems, you have held broken packages.

J'utilise Ubuntu 14.04LTS. J'ai récemment mis à niveau mon système d'exploitation à partir d'ubuntu 13.10. Comment surmonter cette erreur?

La sortie de dpkg -l|grep php  est :

ii  cakephp                                               1.3.15-1                                            all          MVC rapid application development framework for PHP
ii  cakephp-scripts                                       1.3.15-1                                            all          MVC rapid application development framework for PHP (scripts)
ii  libapache2-mod-php5                                   5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        server-side, HTML-embedded scripting language (Apache 2 module)
ii  libedit2:amd64                                        3.1-20130712-2+debphp.org~saucy+3                   amd64        BSD editline and history libraries
ii  libjson-c2:amd64                                      0.11-3+debphp.org~saucy+1                           amd64        JSON manipulation library - shared library
ii  libjson-c2:i386                                       0.11-3+debphp.org~saucy+1                           i386         JSON manipulation library - shared library
ii  libjson0:amd64                                        0.11-3+debphp.org~saucy+1                           amd64        JSON manipulation library (transitional package)
ii  php-gettext                                           1.0.11-1                                            all          read gettext MO files directly, without requiring anything other than PHP
ii  php-pear                                              5.5.10+dfsg-1+deb.sury.org~saucy+1                  all          PEAR - PHP Extension and Application Repository
ii  php5                                                  5.5.10+dfsg-1+deb.sury.org~saucy+1                  all          server-side, HTML-embedded scripting language (metapackage)
ii  php5-cgi                                              5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        server-side, HTML-embedded scripting language (CGI binary)
ii  php5-cli                                              5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        command-line interpreter for the php5 scripting language
ii  php5-common                                           5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        Common files for packages built from the php5 source
ii  php5-curl                                             5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        CURL module for php5
ii  php5-dev                                              5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        Files for PHP5 module development
rc  php5-gd                                               5.4.9-4ubuntu2.4                                    amd64        GD module for php5
ii  php5-imagick                                          3.1.2-1+debphp.org~saucy+1                          amd64        ImageMagick module for php5
ii  php5-json                                             1.3.2-3+debphp.org~saucy+1                          amd64        JSON module for php5
ii  php5-mcrypt                                           5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        MCrypt module for php5
rc  php5-mysql                                            5.4.9-4ubuntu2.4                                    amd64        MySQL module for php5
ii  php5-mysqlnd                                          5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        MySQL module for php5 (Native Driver)
ii  php5-pgsql                                            5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        PostgreSQL module for php5
ii  php5-readline                                         5.5.10+dfsg-1+deb.sury.org~saucy+1                  amd64        Readline module for php5
ii  php5-xdebug                                           2.2.3-2build1                                       amd64        Xdebug Module for PHP 5
ii  phpmyadmin                                            4:4.0.10-1                                          all          MySQL web administration tool
ii  pkg-php-tools                                         1.11                                                all          various packaging tools and scripts for PHP packages

12
2018-05-21 10:09


origine


Quelle est la sortie de dpkg -l|grep php ? - etagenklo
@etagenklo J'ai mis à jour votre sortie dans la question - Ganesh Babu


Réponses:


Il semble que vous ayez installé PHP via le tableau de bord PPA:

https://launchpad.net/~ondrej/+archive/php5

Vérifiez votre apt sources.list si le ppa est toujours actif. Le 14.04, vous devriez avoir ces pensions actives:

deb http://ppa.launchpad.net/ondrej/php5/ubuntu trusty main 
deb-src http://ppa.launchpad.net/ondrej/php5/ubuntu trusty main 

Explication:

Il semble que le référentiel supplémentaire du tableau de bord PHP ait été ajouté auparavant, mais il a été désactivé lors de la mise à niveau de dist. A cause de cela, apt a essayé d'installer php5-gd du référentiel Debian standard, mais cette version nécessite également un php-common standard en tant que dépendance (que vous n’avez pas). En activant le repo du tableau de bord à nouveau, php5-gd a été installé à partir de là et tous vos autres paquets php devraient avoir été mis à niveau vers les versions Ubuntu 14.04 ("dignes de confiance") à partir de ppa.


5
2018-05-21 10:45



Je ne peux toujours pas vérifier votre commande. Je reçois le message d'erreur suivant: deb: commande introuvable. J'ai essayé d'utiliser sudo apt-get install deb.Mais je n'utilise toujours pas - Ganesh Babu
Vous ne devriez pas entrer ceci dans le shell, vous devriez vérifier les fichiers dans /etc/apt/sources.list et /etc/apt/sources.list.d/ pour ces entrées et ajoutez-les si nécessaire. - etagenklo
J'ai ajouté ces lignes dans le fichier que vous avez spécifié. Mais je ne l'ai toujours pas trouvé - Ganesh Babu
Avez-vous publié sudo apt-get update avant d'essayer à nouveau? - etagenklo
J'ai mis à jour ma réponse avec une explication. - etagenklo


Je sais que ça fait un moment pour la réponse originale. Je l’ai installé sur Ubuntu Server 14.04 LTS en installant d’abord sudo apt-get install php7.0-fpm puis courir sudo apt-get install php7.0-gd. Confirmé que cela fonctionne très bien, en particulier pour la génération de captcha qui est mon cas d'utilisation d'une solution tout php. Il n'y a aucune raison de ne pas mettre à jour php5x à ce stade car celui-ci présente de nombreux avantages et aucun inconvénient à ce stade en 2017.


0
2017-10-05 12:45