Question La marionnette ne signe pas de certs


J'ai construit un test pour la marionnette, mais ça ne marche pas. Je commence puppet agent sur le nœud et il attend le certificat.

root:~# puppet agent --server xxxx --waitforcert 60 --test
warning: peer certificate won't be verified in this SSL session
warning: peer certificate won't be verified in this SSL session
warning: peer certificate won't be verified in this SSL session

Sur le serveur, les demandes de certificat en attente sont maintenant trouvées:

root:~# puppet cert --list                                                                                                        
root:~#

Dans le journal masterhttpd:

root:~# tail /var/log/puppet/masterhttp.log
[2012-01-06 09:19:17] xxx - - [06/Jan/2012:09:19:17 CET] "GET /production/certificate/xx HTTP/1.1" 404 30
[2012-01-06 09:19:17] - -> /production/certificate/pgw
[2012-01-06 09:19:47] xxx - - [06/Jan/2012:09:19:47 CET] "GET /production/certificate/xx HTTP/1.1" 404 30
[2012-01-06 09:19:47] - -> /production/certificate/pgw
[2012-01-06 09:19:47] xxx - - [06/Jan/2012:09:19:47 CET] "GET /production/certificate/xx HTTP/1.1" 404 30
[2012-01-06 09:19:47] - -> /production/certificate/pgw
[2012-01-06 09:19:47] xxx - - [06/Jan/2012:09:19:47 CET] "GET /production/certificate/xx HTTP/1.1" 404 30
[2012-01-06 09:19:47] - -> /production/certificate/pgw

Le fichier de certificat est introuvable.


5
2018-01-06 08:29


origine


une fois que vous exécutez la marionnette pour la première fois avec waitforcert activé puis essayez de l'exécuter à nouveau sans waitforcert. Les chances sont que votre cert est déjà signé et c'est pourquoi puppet cert --list est vide. - Aditya Patawari
root:~# puppetca revoke --list 12-01-06 10:25 err: Could not call list: Could not find a certificate for revoke  ne ressemble pas à un cert signé :( - Dennis Wisnia


Réponses:


Je vous recommande de démarrer l'agent de marionnettes en tant que

$ puppet agent --server=xxxx --test --debug

Cette commande vous expliquera plus en détail pourquoi elle échoue. En outre, vous aurez peut-être besoin de plus de temps pour le terminer.

Vous pouvez également essayer de supprimer le certificat des côtés, le cas échéant (respectivement sur le maître et sur l'agent).

puppet --cert --clean your_machine_name

rm -rf /etc/puppet/ssl

1
2018-01-06 09:04



"debug" ne m'apporte aucune nouvelle nouvelle. Il attend le certificat et court dans le délai imparti. Je pense que c'est un problème du côté serveur. - Dennis Wisnia


J'ai rencontré des problèmes très similaires lorsque j'ai commencé avec Puppet. L'option --server n'était pas respectée.

Essayez d’ajouter une entrée à votre fichier HOSTS avec le nom 'puppet' et l’adresse IP de votre box maître.

Si cela fonctionne, la syntaxe suivante fonctionne bien (au moins pour la version 2.7.5)

[main]
logdir = /var/log/puppet
rundir = /var/run/puppet
ssldir = $vardir/ssl
server = puppetmaster.yourdomain.org
pluginsync = true

[agent]
classfile = $vardir/classes.txt
localconfig = $vardir/localconfig
server = puppetmaster.yourdomain.org
listen = true

1
2018-01-06 15:10





On dirait que vous avez vérifié que l'agent est en train de contacter le maître. Bon premier pas.

Ensuite, comme d'autres l'ont suggéré, vérifiez que le certificat n'a pas été signé et qu'il ne vous a pas manqué:

sudo puppet cert --list --all

Si vous ne le voyez pas là, je nettoierais tout et recommencerais.

Tout d'abord, vérifiez que la date et l'heure sur les deux serveurs sont synchronisées. Vous pouvez forcer une synchronisation NTP avec quelque chose comme ntpd -q -g, en fonction de votre distribution et de votre client NTP.

Ensuite, lancez un clean sur le maître de marionnettes:

sudo puppet cert clean <agent hostname>

Sur l'agent, nettoyez tous vos fichiers SSL:

sudo rm -rf /var/puppet/ssl /var/lib/puppet/ssl/ /var/puppet/ssl 

Enfin, lancez un test:

sudo puppet agent --debug --test --server <master hostname>

Espérons que si cela ne résout pas le problème, cela devrait vous donner des indices sur les endroits où chercher.


1
2018-01-09 04:27