Question Problèmes d'installation de tableau de bord marionnette


J'utilise Ubuntu 12.04 LTS (32bit, Server), marionnette 2.7.17, ruby ​​1.8.7.352 rubygems 1.8.15. et Apache 2.2.22.

Lorsque j'essaie d'exécuter la commande pour migrer la base de données,

<server>:/usr/share/puppet-dashboard# rake RAILS_ENV=production db:migrate

Je reçois l'erreur suivante:

NOTE: Gem.source_index is deprecated, use Specification. It will be removed on or after 2011-11-01.
Gem.source_index called from /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/gem_dependency.rb:21.
NOTE: Gem::SourceIndex#initialize is deprecated with no replacement. It will be removed on or after 2011-11-01.
Gem::SourceIndex#initialize called from /usr/share/puppet-dashboard/config/../vendor/rails/railties/lib/rails/vendor_gem_source_index.rb:100.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
NOTE: Gem::SourceIndex#add_spec is deprecated, use Specification.add_spec. It will be removed on or after 2011-11-01.
Gem::SourceIndex#add_spec called from /usr/lib/ruby/vendor_ruby/1.8/rubygems/source_index.rb:91.
rake aborted!
no such file to load -- rdoc/task

(See full trace by running task with --trace)

Quand j'ai d'abord essayé de démarrer le service tableau de bord marionnettes, il s'est plaint de ne pas trouver de rake ~> 1.1.0, alors j'ai installé ça.

Maintenant, j'obtiens l'erreur suivante:

Missing these required gems:
 rack  >= 0

Toutefois...

# gem list
*** LOCAL GEMS ***
hiera (0.3.0)
rack (1.4.1, 1.1.0)
rack-test (0.6.1)

le rack est clairement installé. Après avoir lu cette question J'ai même enlevé le rack 1.4.1 ne laissant que 1.1.0, mais j'ai la même erreur.


5
2017-07-10 21:21


origine




Réponses:


Le tableau de bord des marionnettes indiquait de ne pas utiliser la version rubygems dans 10.04 LTS, mais ne disait pas que la version empaquetée dans 12.04 LTS ne fonctionnerait pas non plus.

Après une suggestion de la liste de diffusion, j'ai exécuté le script indiqué dans le manuel de puppet-dashboard et rétrogradé mon installation gem en 1.3.7.

J'ai aussi installé le joyau rdoc.

Entre ces deux changements, le problème a été résolu.


2
2017-07-11 13:50





Sur une toute nouvelle installation du serveur Ubuntu 12.04 AMD64, j’ai exécuté les deux commandes suivantes pour obtenir le db:migrate travailler:

sudo gem install rack --version=1.1.0
sudo gem install rack --version=1.1.2

Autre que ce changement, j'ai suivi la documentation d'installation exactement et cela a fonctionné. Je ne sais pas si ces deux éléments sont nécessaires, mais le premier seul modifie légèrement le message d'erreur. :-)


1
2017-07-20 02:49





Vous pourriez également être intéressé par Ruby Version Manager. Cet outil prend en charge plusieurs environnements Ruby sur le même boîtier, sans conflits de gemmes.

https://rvm.io/gemsets/basics/

https://rvm.io/workflow/rvmrc/


1
2018-04-10 15:08