Question Pourquoi est-ce que cela m'empêche d'installer un MSI? L'administrateur système a défini des stratégies pour empêcher cette installation.


J'essaie d'installer un fichier MSI sur un ordinateur Windows Server 2012 qui fait partie de mon domaine de laboratoire. Je suis administrateur local et de domaine, mais il semble que je ne peux pas installer ce MSI.

Pour plus de précision, lors de la tentative d’installation de l’extension git pour visual studio (situé ici) connecté en tant qu'utilisateur de domaine appartenant au groupe des administrateurs, le message d'erreur suivant s'affiche:

enter image description here 

La machine signalant l'erreur est un Windows Server 2012.

Je suis presque sûr que cela doit être une sorte de restriction de stratégie de groupe? Aucun n’aura été défini, sauf s’il s’agit du niveau de sécurité par défaut.

Pour plus de précisions, j'aimerais savoir Qu'est-ce qui empêche l'installation de ce fichier MSI par un administrateur de domaine?


26
2018-03-10 09:23


origine




Réponses:


Après avoir passé du temps à examiner la politique du groupe, autant que je sache, rien n’était pertinent. Je suis ensuite tombé sur ce post qui suggère que j'essaie de lancer une commande promt en tant qu'administrateur et en cours d'exécution

 msiexec /a install.msi

Cela a semblé fonctionner, mais a fonctionné très rapidement - en fait il n'a pas. Sur un coup de tête, j'ai essayé ceci à l'intérieur de l'invite de commande admin.

 msiexec /i install.msi

qui a fonctionné un régal.


35
2018-03-10 20:06



Cela fonctionne mais cela peut être irritant de le faire chaque fois que vous installez à partir d’un msi. Voir la réponse d'Armin Sadeghi ci-dessous pour une solution à long terme. - Jake


J'ai rencontré ce problème, où l'installation de MSI est empêchée avec "auparavant, l'administrateur système a défini des stratégies pour empêcher cette installation". Je pense que cela est dû à la stratégie de restriction logicielle Windows par défaut et je l'ai vue à la fois sur Windows Server 2008 R2 et Windows Server 2012.

Il existe probablement un meilleur moyen basé sur l'interface graphique pour modifier la stratégie, mais définir la clé de registre suivante en tant qu'administrateur sur la machine suffit:

[HKEY_LOCAL_MACHINE\SOFTWARE\Policies\Microsoft\Windows\Installer]
"DisableMSI"=dword:00000000

13
2018-04-15 06:59



Cela fonctionne à 100% - Jan Chrbolka
Cela a fonctionné pour moi. Je devais ajouter la partie "Installer" du chemin en tant que clé, puis ajouter le DWORD "DisableMSI" (sans les guillemets). - Mike S


Cela est généralement dû à une stratégie de groupe ou à une stratégie locale désactivant Windows Installer.

Regardez sur votre contrôleur de domaine si vous avez un objet de stratégie de groupe désactivant "Windows Installer": Configuration de l'ordinateur> Modèles d'administration> Composants Windows> Windows Installer> "Désactiver Windows Installer".

Vérifiez qu'il est réglé sur "Non configuré" ou "Désactivé".

Si vous ne le trouvez pas dans vos objets de stratégie de groupe, consultez les stratégies locales de l'ordinateur à l'aide de gpedit.msc.

Remarque: le fait que vous soyez un administrateur de domaine n'a pas d'importance. Tout dépend de la portée de l'objet de stratégie de groupe.


2
2017-07-15 21:25



Verify that it is set to "Not configured" or "Disabled". Ce n'est pas vrai. La valeur par défaut (non configuré) est 1 ce qui signifie managed only. msdn.microsoft.com/en-us/library/aa368304.aspx Désactivé en termes de gpos signifie que la stratégie sera désactivée, ainsi la clé de registre sera supprimée et la valeur par défaut sera utilisée. Le son est étrange mais il faut choisir Enabled et sélectionnez Never dans la liste déroulante. - Jürgen Steinblock


Nous avons eu exactement le même problème lors de la construction d’une MSI en utilisant IsCmdBld.exe, mais pas lors de la construction à partir de l'interface utilisateur du logiciel InstallShield.

Lors de l'exécution du programme d'installation, l'erreur mentionnée par l'OP s'afficherait et le journal d'installation afficherait: MSI_LUA: Invalid Descriptor Format.

Le problème était dû au fait que nous transmettions une valeur ProductCode Guid à la ligne de commande IsCmdBld.exe, comme suit: -z "ProductCode"="f176c219-dec0-4fa9-a373-94a711f28a3d".

Vous pouvez voir que le Guid fourni ici n'est pas entouré de { et }.

Nous l'avons corrigé en passant le guid avec des crochets autour de: -z "ProductCode"="{f176c219-dec0-4fa9-a373-94a711f28a3d}" qui fonctionne comme prévu et n’affiche plus l’erreur.


1
2018-06-11 20:48





clic droit -> exécuter en tant qu'administrateur


0
2017-10-26 18:17



En quoi est-ce différent de la réponse acceptée? - Dave M


Ni les correctifs de msiexec ni du registre ne fonctionnaient pour moi (même après le redémarrage), mais la désactivation du contrôle de compte d'utilisateur (comme suggéré par Ha Ly dans ce fil) et le redémarrage a fait l'affaire.


0
2017-08-25 22:58





Vous avez la possibilité de désactiver le contrôle de compte d'utilisateur via le registre en modifiant la DWORD  EnableLUA de 1 à 0 dans HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\policies\system. Vous recevrez une notification indiquant qu'un redémarrage est requis. Après le redémarrage, le contrôle de compte d'utilisateur est désactivé.


-2
2018-06-02 15:09