Question la connexion mysql est lente (5 secondes)


Après avoir construit ma webapp sur un premier démarrage, je crée 2 connexions à mysql sur debian, puis 1-2 (r / w) pour chaque page suivante. La connexion prend constamment 5,2 secondes pour se connecter. Debian est dans une machine virtuelle en cours d'exécution dans mon système d'exploitation. Pourquoi la connexion dure-t-elle si longtemps?

Parfois, cela prendra <0,1 seconde, ce qui est excellent, mais 5,2 x 2-3 à chaque exécution est trop. Quelqu'un at-il rencontré ce problème? Comment puis-je le résoudre?

remarque: j'utilise .NET pour me connecter. Pas que ça compte. et son mysql v5

-edit- Après avoir vérifié les paramètres du pare-feu et fait beaucoup de choses, je ne pouvais pas comprendre le problème. J'ai trouvé une version noinstall de MySQL et je l'ai utilisée. Les connexions sont rapides comme l'éclair.


5
2018-05-23 03:18


origine




Réponses:


La confusion peut être juste. La première chose que je voudrais vérifier est le reverse DNS. Pour résoudre ce problème, essayez de définir l'indicateur --skip-name-resol sur mysqld:

http://dev.mysql.com/doc/refman/5.0/en/server-options.html#option_mysqld_skip-name-resolve

Assurez-vous également d’ajouter votre nom d’hôte / ip à / etc / hosts


6
2018-05-23 08:05



Nous avons eu ce problème. À chaque connexion (même si vous utilisez une adresse IP), le serveur mysqld procédera à une recherche inversée de votre adresse IP. Si vous ajoutez skip-name-resol au fichier my.cnf, cela sera ignoré. Le délai d'attente DNS est de 5 secondes. - Slashterix


Utilisez-vous un nom d’hôte ou une adresse IP pour vous connecter? On dirait que vous rencontrez peut-être une résolution DNS lente.


3
2018-05-23 03:51



mais sa ... sur ma comp locale et VM. Pas même le réseau. Je spécifie l'adresse IP et l'hôte est win7


Si vous êtes sur un système Debian, j'ai remarqué que le fait d'exécuter le démon mDNS avahi peut être à l'origine de problèmes. J'ai remarqué cela parce que je pouvais faire des recherches instantanées en avant et en arrière via dig, mais j'avais toujours un délai de 5 secondes pour la connexion à mysql. En regardant une capture de paquet, je pouvais voir 3 requêtes mDNS plus de 5 secondes avant que la connexion ne soit établie. La désactivation ou la désinstallation du démon avahi a résolu ce problème pour moi.


1
2018-01-11 16:08





J'envisagerais de passer en revue la configuration du pare-feu sur la machine hôte.

S'agissant d'une machine virtuelle, il est possible que la connexion de l'application Web à la base de données soit examinée par le pare-feu ou le filtre de contenu en cours d'exécution sur la machine hôte.


0
2018-05-23 05:21