Question SSH utilise seulement mon mot de passe, ignore ma clé ssh, ne me demande pas de mot de passe


Cette question concerne le client OpenSSH sous Linux, MacOSX et FreeBSD.

Normalement, je me connecte aux systèmes à l'aide de ma clé SSH.

Parfois, je souhaite que mon client SSH ignore ma clé SSH et utilise plutôt un mot de passe. Si je m'appelle 's hostname', mon client me demande de saisir la phrase secrète de ma clé SSH, ce qui est un inconvénient. Au lieu de cela, je veux que le client ignore simplement ma clé SSH, afin que le serveur me demande mon mot de passe.

J'ai essayé ce qui suit, mais je suis toujours invité à entrer la phrase secrète de ma clé SSH. Après cela, je suis invité à entrer mon mot de passe.

ssh -o PreferredAuthentications=password host.example.org

Je veux le faire côté client, sans aucune modification de l'hôte distant.


119
2018-04-07 23:07


origine


stackoverflow.com/questions/6377009/… - Ciro Santilli 新疆改造中心 六四事件 法轮功
@CiroSantilli 死 六四 事件 法轮功 Veuillez décrire pourquoi ce lien serait utile au lieu de publier un lien simple sans contexte. - Stefan Lasiewski


Réponses:


Essayer ssh -o PreferredAuthentications=keyboard-interactive,password -o PubkeyAuthentication=no host.example.org

En ssh v2, keyboard-interactive est une autre façon de dire "mot de passe". le -o PubkeyAuthentication=no L'option indique au client de ne pas tenter l'authentification par paire de clés.


165
2018-04-07 23:13



Et en fait, "ssh -o PreferredAuthentications = hôte interactif au clavier" fonctionne également. SSH_CONFIG (5) m'a laissé tomber. Il mentionne toujours le mot clé 'password'. Merci pour la clarification. - Stefan Lasiewski
Correction: dans SSH v2, tous les deux  password et keyboard-interactive sont valables, et ce sont des choses différentes. (password nécessite un mot de passe, et keyboard-interactive peut techniquement être n'importe quoi.) - grawity
Bill, pourriez-vous mettre à jour votre réponse en fonction du commentaire de Grawity? Observez le résultat de ces commandes: lucian @ XXX: ~ $ ssh -o PreferredAuthentications = keyboard-interactive -o PubkeyAuthentication = no host.example.org Permission refusée (publickey, gssapi-with-mic, mot de passe). lucian @ XXX: ~ $ ssh -o PreferredAuthentications = mot de passe -o PubkeyAuthentication = no host.example.org Le mot de passe de lucian@host.example.org: - Lucian Adrian Grijincu
À quoi ressemble votre configuration de serveur? Je n'ai jamais vu cette différence. De plus, cela ne répondrait pas à la question initiale, ils essayaient un mot de passe. - Bill Weiss
Si vous voulez ajouter ce commutateur au fichier de configuration de ssh (~ / .ssh / config), c'est PubkeyAuthentication no dans ce fichier. - slm