Question Ajouter un certificat auto-signé aux certificats de confiance dans cURL sous Windows?


J'ai créé un certificat auto-signé à partir des instructions du cette page, l'avez installé et il semble que tout fonctionne correctement, mais maintenant, j'ai besoin de cURL faire confiance.

Comme les dernières versions de cURL n'incluent pas de liste de confiance dans un .pem fichier, j'ai téléchargé le fichier .pem ici puis entrez cette ligne dans php.ini:

curl.cainfo = "C:\xampp\php\cacert.pem"

Maintenant, tout ce que j'ai besoin de savoir, c'est comment puis-je obtenir cURL faire confiance à mon cert auto-signé? Je n'ai besoin d'aucun navigateur pour y faire confiance, mais simplement cURL.


6
2017-10-05 10:00


origine




Réponses:


Tout ce que je devais faire, c’était d’ouvrir le cacert.pem déposer et ajouter le contenu de la server.crt déposer à ce sujet.

Pour ceux qui lisent, server.crt est le fichier créé lors de la création du certificat auto-signé et que j'ai copié dans: C:\xampp\apache\conf\ssl.crt\server.crt


6
2017-10-05 10:20



Bonjour, j'ai essayé avec la solution ci-dessus suggérée et de nombreuses autres options avec d'autres blogs, mais je suis toujours confronté au même problème. Suggère de bien vouloir - Hiren Soni
@HirenSoni Je créerais une nouvelle question avec votre problème et votre code afin qu'il soit plus facile de réduire votre problème. En faisant votre cURL appelez, vous devrez peut-être inclure le chemin comme curl_setopt($ch, CURLOPT_CAINFO, 'curl_path_here'; - Brett
Merci pour ta réponse rapide. Le problème, c’est que j’utilise composeur pour télécharger le package et que le référentiel est protégé avec SSL. Le problème est donc survenu lors du téléchargement du package avec composer. - Hiren Soni
@HirenSoni Dans ce cas, l'utilisation d'un certificat SSL auto-signé sur votre ordinateur local ne devrait en aucun cas être utilisée. On dirait que vous avez besoin du protocole que vous utilisez pour vous connecter au référentiel afin de faire confiance au certificat SSL qu'ils utilisent; probablement un peu en dehors du champ de cette question et mieux en créer une nouvelle? - Brett
Merci pour la mise à jour, je vais essayer de mettre à jour au cas où je trouverais une solution. - Hiren Soni