Question Comment enregistrer la configuration d'iptables sur Redhat Enterprise Server 7


J'ai un serveur Redhat (Red Hat Enterprise Linux Server release 7.2 (Maipo)) qui réinitialise les règles iptables lors du redémarrage.

Selon le documentation de la version 6, J'exécute:

/sbin/service iptables save

qui retourne:

The service command supports only basic LSB actions (start, stop, restart, try-restart, reload, force-reload, status). For other actions, please try to use systemctl.

Si j'ai bien compris le message, j'ai tenté les choses suivantes:

sudo systemctl iptables save

qui retourne:

Unknown operation 'iptables'.

Je n'arrive pas à localiser le documentation de la version 7 lors de la sauvegarde de tables ip spécifiquement, mais les versions précédentes supportent la même commande.

Quelle commande dois-je lancer pour enregistrer iptables config?

Pour référence:

pare-feu d satatus:

systemctl status firewalld
firewalld.service
   Loaded: not-found (Reason: No such file or directory)
   Active: inactive (dead)

6
2017-09-06 13:54


origine




Réponses:


Vous devriez installer iptables-services paquet.

ensuite service iptables save marchera. De plus, ces commandes fonctionneront aussi:

# iptables-save > /etc/sysconfig/iptables
# ip6tables-save > /etc/sysconfig/ip6tables

Autant que je sache, systemctl n’a aucune option pour enregistrer la configuration de iptables-services.

Remarque: la syntaxe de systemctl est la suivante: systemctl <operation> <unit>


10
2017-09-06 14:14



En passant, je ne recommande pas les moyens ci-dessus si les changements de règles sont permanents. Je choisis de garder les commentaires sur les règles dans /etc/sysconfig/iptables fichier que les administrateurs système doivent faire afin de fournir des informations aux futurs administrateurs ou juste un rappel. Si vous enregistrez la configuration avec les commandes ci-dessus, les commentaires seront perdus. Utilisez simplement un éditeur de texte pour éditer le fichier et recharger le service avec systemctl. - aesnak


Voici un lien vers le Guide de sécurité pour Red Hat 7: using_firewalls

j'utilise

# cat /etc/redhat-release
Red Hat Enterprise Linux Server release 7.4 (Maipo)

Et le statut de pare-feu un service:

# systemctl status firewalld
Active: active (running) since Fri 2018-04-13 10:00:18 CEST; 31min ago

Donc je pense que vous pourriez aussi activer le pare-feu un service:

systemctl start firewalld
systemctl enable firewalld

Et changer les règles via pare-feu-config

  1. presse Super
  2. Type pare-feu,
  3. Sélectionner Permanent dans le menu déroulant
  4. Mettez les réglages nécessaires

0
2018-04-13 08:44